Laravel – Missing mcrypt on Ubuntu [SOLVED]

Just a quick techie post in case it helps anyone.

I’m having a look at the Laravel php framework, went to install a test project using the command:

composer create-project laravel/laravel --prefer-dist

And my terminal throws an error:

- laravel/framework v5.0.12 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.

A quick check of /etc/php5/mods-available shows it’s there, a quick phpinfo() shows it’s enabled.

However.  That’s for Apache, and not for the command line version of php.  I needed to enable it at the command line.

cd /etc/php5/apache2/conf.d/
sudo cp 20-mcrypt.ini ../../cli/conf.d/

Re-run the initial composer request and it worked first time.

Next up…  Actually creating a Laravel app, not just installing the framework!

Leave a Reply

Your email address will not be published. Required fields are marked *